❌ À propos de FreshRSS
Il y a de nouveaux articles disponibles, cliquez pour rafraîchir la page.
Hier — 24 septembre 2020Vos flux RSS

Release notes

Par : jgeduldig
Is there a document that lists fixes and other changes between versions of NDI SDK and NDI Tools?

Unable to connect my phone to Virtual Input

Par : Nic Dr
I have the newest versions on both Virtual Input on PC and NDI HX Camera on my iPhone 7. Virtual Input can't find my phone when i use the camera app on my phone, it says: " No NDI sources found."
I used this app in june for school and worked perfectly fine and now it can't seem to work, also for school.

Unable to load kernel driver (video)

Par : tomgo

I have used NDI Tools (specifically NDI Virtual Input) for a while now on my old laptop under Windows 10 Enterprise Version 1909.

Since last week I have a new laptop (Microsoft Surface Book 3) which had Windows 10 Version 2004 preinstalled. I have change the license to Enterprise and installed all latest updates. Then I ran a script from my companies IT admins which was basically installing a virus scanner and made some basic settings like mounting common shares.

When I install the latest NDI Tools 4.5 now (just downloaded few days ago) everything looks good first (no error messages). But when I start NDI Virtual Input then (same behavior with or without reboot) I get the following error message.

Click image for larger version. 

Name:	2020-09-17_02-20-32.png 
Views:	8 
Size:	13.9 KB 
ID:	148734

In the UEFI menu I have disabled secure boot completely (no change). Also, I have put the OS into kernel driver test signing mode (no change). I reinstalled NDI Tools several times under these different conditions (no change).

I wonder if this is a known issue. It looks to me that there is something different on my machine which "NDI Virtual Input.exe" is not able to deal with. All other hardware drivers are working completely fine, so it might not be a general problem.

Can somebody perhaps tell me what exactly is the condition which is causing this error message?
Attached Thumbnails
Click image for larger version. 

Name:	2020-09-17_02-20-32.png 
Views:	N/A 
Size:	13.9 KB 
ID:	148734  

Install failure

Par : KRTW
Hi. NDI is fantastic technology and I hope I can get this working.....I've installed thousands of programs and never seen anything like this. So I signed up, got my link, did the download, ran this install and everything seemed to go well. THen I started the app NDI Studio, and it started the install program for my Yamaha ASIO drivers.....yup. Starting the program ran a program to install Yamaha ASIO drivers, that are already installed....first time I just cancelled the install, but it would not shut down....So I rebooted and tried again....but the install program was still running so I had to power off and remove the battery....then I tried to run the NDI Studio again, and the install started....there were error messages and the install ran forever....I had a show to run, so again shutdown, powered off and gave up.

Any ideas here?

NDI Access Manager - discovery service

Par : herlsone
Is there more detail on how these tools work? I see access manager stores data in a appuser roaming xml file. But it does not store the discovery server data in that file and I cannot find another location of data being stored.

If you use discovery service, does it completely ignore the output and receive groups?
What defaults are needed in groups?
If discover server is enabled are any ports needed to be forwarded at all? or can all machines now see and receive what the server is keeping track of?

Any tutorial at all??


NDI app priority on same PC

Par : fgolman
Never mind, post deleted.


Fritz Golman
Museum of Broadcast Communications

Scan converter - region of interest displaying green bars when taken as input

Par : hypohamish
So, best way I can show this is with a GIF

I have scan converter set up on a laptop to capture a region of interest (screenshared powerpoint from zoom)

I'm taking that as an input over NDI into Vmix - but when received into Vmix, I see these weird little green bars. The bars move/change shape when I resize the ROI on the laptop.

They do not however appear at all on the laptop or at any point with configuring the ROI.

Is this an NDI/Scan converter issue, or is it a Vmix one? A colleague with the exact same setup doesn't experience this.

MacBook issues sending Keynote with video backgrounds

Par : highab
We have an all-mac system. We've been using it OK for 6 months now.

I have, however had to be creative in sending a keynote from a macbook pro 2012 to the network, yes it's old but we tried the same file with a newer macbook and still things didn't work quite right.

We've been using VmixDesktop capture of Display 2 over the network without problems for our iMacs and MacMini since showing screen 2 of a MacBook Pro via NDI scan converter seems impossible since to select Keynote screen 2, Keynote screen 2 needs to be activated and if it's activated then keynote blocks us from going into NDI scan converter and selecting the feed to be sent or making any changes to the quality of the feed.

When we tried a macbook with VmixDesktop capture of a file with a video background we did have output BUT:

1) The slide shown via HDMI and the slide shown via NDI were not always the same and sometimes took forever to catch up
2) The background video stuttered, it wasn't nice and smooth as it should be.

I have been doing tests with a different laptop mac that doesn't have much RAM at the moment. Even if I remove the background video from the Keynote file and play just the background video using QuickTime player, it plays properly, waits a bit and then plays again, it's never a smooth feed, whereas playing something on YouTube and showing it over NDI seems to work without any problems, proving that the NDI feed can work.

So although I do have a workaround solution, sending the feed via HDMI into our video switcher and using the feed from the video switcher as the NDI source which then outputs video that is very smooth. I'd really like to understand what the problem is.

I've tried manual ethernet configuration on the 2 tests macbooks, setting it to Jumbo but I don't know what else to try.

The NDI signal taken from the video converter via a BirdDog mini works just fine, so it doesn't look like the problem is the network.

Does anyone have any ideas or point me in the direction of other tests to do to try to work this out?

Many Thanks!

NDI & Sony SRG-X120 - No picture

Par : kadams79
Recently purchased a Sony SRG-X120 to use for live streaming via OBS. I currently have the camera and computer connected via ethernet to a Linksys EA9500 router. The computer is Windows 10 with a Gigabit ethernet port. Camera firmware has been updated, the NDI license has been added to the camera, and it shows as a NDI source in Studio Monitor. Unfortunately there is no picture. I've looked through the forums and Google articles for two days with no luck. Can anyone help me figure out what I'm missing?
Click image for larger version. 

Name:	IMG1.png 
Views:	6 
Size:	298.0 KB 
ID:	148707
Attached Thumbnails
Click image for larger version. 

Name:	IMG1.png 
Views:	N/A 
Size:	298.0 KB 
ID:	148707  

NDI 3.0+ Runtime

Par : NightFox
I am looking for this version I need the NDI 3.0+ Runtime PKG for macOS. Does anyone have a copy of this? For I have an older Mac that I am running with max OS 10.11.6 and I would like to have NDI put on it so I can run a or IEEE 1394 Camera. But I having a nightmare of a time trying to find an archival for this program

I would use the new version but it would seem that El Capitan does not work well with any anything above OBS 19.x and that means that only NDI 4.2.2 will work with that version and it needs the NDI 3.0 Runtime.

Any help would be greatly appreciated.

Unless you can help me to understand how to get a new version of OBS to work correctly and will work with the NDI 4.5.1 run time.

One of the problems is related to the fact that with the OBS 24.x, 23.x, 22.x version is that it will either not allow the transition to other scenes or will keep the program screen black. For I see the image in the Preview under studio but when you try to translate it to the program view or streaming view, the screen remains black.

Thank you in Advance

No audio from NDI source in OBS

Par : thomasvt
Not displaying any audio levels on a Win 10Pro laptop. Have checked and do not see any issues with OBS settings.

I have tried from another Win 10 computer and that seems to be working okay. Also tried from Ubuntu laptop and it works okay.

Have run the NDI Analysis tool on the two Win 10 laptops for comparison and the output files are attached.

Is there anything I need to check on the Win 10 laptop to get the NDI audio working. Could it be any firewall or AV which may be filtering audio. Is there anything I need to check on the NDI drivers?
Attached Files

Embedded SDK Documentation

Par : pjde
Greetings All

I downloaded and installed the Windows Embedded SDK however the documentation is for the standard SDK even though the installation provides links to non-existent Embedded SDK documentation.



Talkshow 4000 over NDI horribly jittery on a brand-new TC1...

Sorry for the cross-post over in the Talkshow forums, but this is an issue I *have* to get fixed.

Just last week I traded in my TC460 (bye-bye W7) for a TC1. The install went well, everything seemed to be in line, but in testing with our pre-existing Talkshow 4000, it has become pretty obvious that in the path from the TS to the TC1 something is quite unhappy. The video in the TC1 is jittery and wildly out of sync. Luckily I can record the Talkshow signals internally - that saved my butt on a high-profile guest last week on a taped show - but the majority of our shows are live, with from one to four Skype channels in operation.

So: Anyone have any insight? As you might expect, our LAN in the building is basically wide-open, with everyone working at home. In fact, the only variable here is the TC1 - the 460 had no issue with the Talkshow signals.

Is there some "best practice" for the TS4000 and the TC1 I may have overlooked?

Thanks all -
À partir d’avant-hierVos flux RSS

NDI|HX Dropouts and Missing Info in NDI Analysis

Par : CUCMedia
We are experiencing audio dropouts when receiving NDI video from Newteks NDIHX-PTZ1 and PTZ Optics cameras on our corporate network. Dropouts have occurred when receiving video with either Studio Monitor or the Tricaster TC1. In an effort to diagnose the issue we turned to the NDI Analysis app (see attached reports). There both the Newtek and PTZ Optics cameras report using an unknown codec and data rates of zero. The TC1 report looks normal, though the "Video recv" variation is a bit disconcerting. This all brings me to my question:

Is the missing data in the NDI Analysis report a stem from an inability to parse the information from an NDI|HX stream or another symptom of poor network or machine configuration?

9.9.2020 - NDI Analysis - NDIHX-PTZ1.txt
9.9.2020 - NDI Analysis - PTZ Optics Camera.txt
9.9.2020 - NDI Analysis - Tricaster TC1.txt

NDI-HX on iPhone to Screenflow Blocks Audio

Par : geopick
I am using NDI-HX to send video to Screenflow on my iMac. The video works fine, but when I mute audio on the iPhone and set audio input to NDI Audio no sound is recorded. With NDI Virtual Input active, neither the iMac's internal microphone nor an external USB microphone record audio. I am wondering if the problem is an incompatibility between Screenflow and NDI Virtual Input?

Diagnosing inconsistent frames with the Analyzer of NDI HX camera's

Par : ryzen6652
Hello guys, I hope to gain some knowledge here to help me along.

First just a brief summery of my technical setup
I often have setups with multiple PTZ cams, all wired up to a workstation running vmix.
All cams are NDI HX and about 50% of then run 4k 30fps, and the other 1080p 60fps.

Since the start the 4k cams have given me somewhat inconsistent performance that tends to get worse with scaling out, and i can't seem to really pinpoint what the weak point is.
With a framerate of 30fps it is just not as smooth that you would think, its just always a bit of stutter here and there.

Its a closed system, with only 1 network hop/switch so no mdns or any other factors.
The workstation is a 24core TRX with 64gb ddr4 3600mhz and a RTX 2080s, so more than enough power.
It is linked to the main switch with a 10gigabit Ethernet port and the PTZ are linked to the 1gb Poe+ ports on the switch so bandwidth is plenty.

I tried lots of tweaks on the switch, some seem to influence things a bit but nothing that got the desired result.
Same inconsistent behavior is also present when just linking a camera directly in the workstation.

So the NDI analyzer looks really promising to diagnose the camera's and changes in the network switch, but i have some problems to interpret the given results, even after reading the included documentation.

I have noticed the video recv value is very depended on resolution, bitrate and encoding parameters.
But when setting everything so it goes as low as possible it results in vmix dropping most frames, so now i wonder if its better to focus on deviation in between reported values instead of absolutes?
Also some of my values are so far of the quoted values in the documentation I am wondering how can this give sort of smooth image, or am i understanding this poorly.
I'm not ruling out the cameras are to blame because there Chinese OEM sold by local company camera's that are fairly priced accordingly.
Although i found out this is the same OEM that builds ptz optics, hubble cam and a couple of other big brands so they should have some knowledge.

I would like to understand the analyzer better so i can optimize as much as possible with the given hardware.

So i hope to get some tips and pointers.

I have added a txt from 3 ndi analyzer runs.
1 is 4k 30fps bitrate 52100 - the OEM added that high bitrate sort on my request for preventing compression artifacts in very complex scenes.
2 a 4k 30fps bitrate 10240 - Half bitrate of what normally is max
3 a 720P 30fps bitrate 10240 - as a very low end control run

any help is appreciated.
Attached Files

NDI Studio Monitor unable to run on my computer

Par : abo

Windows 10 2004 up to date
NDI Tools 4.5

Studio Monitor displays the following error Window
Error running Video Monitor

Your GPU cannot run Video Monitor.
OpenGL Shaders not supported.

But …
Up to date drivers (12 august 2020) from NVIDIA site are installed for my graphics card (NVIDIA GeForce GTX 1660 Ti with Max-Q Design).
The drivers support OpenGL 4 …. including Shaders ….

Therefore I suppose that Studio Monitor detects wrong graphics card.
There is a second GPU (Intel UHD Graphics 630) on my laptop.
But this GPU is disabled and must remain disabled.

Most probably this is a bug in GPU detection by Studio Monitor.

Do you have any idea on how to fix it*?
Any help will be appreciated

VLC zoom on video out

Par : alonso
Hi! i'm playing a mp4 video on VLC

but the output that VLC send is like the video has a zoom effect applied

Unlock corporate network for ND HX Camera App

Par : theliadir
I use the NDI plugin with OBS and the ND HX app on the iPhone.
With the wireless at home this works perfectly. At work I unfortunately don't get the NDI source in OBS. I guess it's somewhere blocked in the network.
Now I want to ask our IT department if they can somehow enable our network to support it.
Can I send any information to my IT department on what the have to change in our network? Forwarding a port, ...

IOS HX camera confiuration on Access manager


I currently have this setup, 2x laptop on scan converter, 1x z840 workstation on studio monitor and 2x IOS device with HX camera app.
All works fine with all device are connected on the same wifi network.
I have move the workstation to ethernet (same vlan setting with wifi) and mDNS discovery stop working, as a workaround I used Access manager to manually input the ip address of all the devices.
Studio monitor on the workstation is able to capture both scan converter laptop but somehow the IOS HX camera is not broadcasting any video. Both laptop/iphone are configured as NDI sources type.

Any advise would be appreciated.


Adobe CC plugin after effects

Par : alonso
Hi friends,
I`m using adobe cc for premiere and work fine. sending that signal to tricaster.
but now i`m triying to work with after effects, it send the video but not alpha channel is active.

there is an extra step that i´m missing?

NDI Virtual Input / NDI Audio Device issues on Mac

Par : Groberoo
Has anyone else had any issues on a Mac (Catalina 10.15.6) with the NDI Virtual Input app? Specifically the audio side of things. I’m having trouble getting any audio from a Panasonic CX-350 via Virtual Input.

It works fine via that Video Monitor app but using Loopback to monitor the NDI Audio Device shows no levels at all.

NewTek support were helpful to a point but then decided to blame the software package I am trying to get the audio into.. even though I can’t get any NDI audio at OS level.

NewTek support did point out that the Windows version of Virtual Input has volume controls from the system tray but the Mac version doesn’t and the preferences option from the Main is ghosted.

Support have now said they can’t help me any further which is disappointing so does anyone have any ideas?


NDI versions and legacy tricaster

Par : alonso
I try to figure out some things about ndi versions.

If I understand well, 460 with AE2 don't work with NDI 4.
3.8 and below that right?

So when I use NDI cam with HX2, there is a big screen that say need update ndi Tricaster version.

So my question, in an ecosystem with other products. My 460 wouldn't work?

If there is an obs and vmix that would connected with 460. Both software can update their version of NDI wirhout a problem.
So the video that they send will not recognized by 460. So every software with new version of NDI couldn't be work with my 460?
So that equipment will work like and island isolate from de new ndi word.

If the statement above is right. There is a king of solution?
The signal of NDI 4 could pass thought I don't know a connect pro and can be compatible with 460?

Also what about ndi converter hardware?
They depend of NDI version in order to work?

Problem with NDI and Dante on same computer

Par : ZachS
I have a Panasonic AV-HLC100, which looks like a white-label “Micro” Tricaster. That I would like to have Dante Virtual Soundcard or Audinate AVIO-USB adapter to receive the audio from our mixer.

Our problem is with our projection computerI(Windows 10) creates a popping/click sound the Dante network when we start NDI Scan Converter. I’m using NDI This computer has a second network card, the primary interface is used for internet and NDI traffic, the second interface is used for Dante traffic only with Dante Virtual Sound Card. Without Scan Converter running, the audio is just fine.

I’ve tried to add host based firewall rules in McAfee Endpoint Security to deny connection either way to the Panasonic video mixer on the Dante Network. With a lower rule to allow all hosts on the Dante network to make connections.

I’ve also turned off Spanning Tree Protocol in my Unifi Switches. Mulitcast is turned on.

Does anyone have a way of getting NDI and Dante to play nice together? I’ve done some searching and others have proposed to have an option in NDI for which interfaces that it’s allowed to talk to. I think with the complexity of networks today, this would be an essential feature.

HX2 not working on MAC, only on windows

I have a strange situation. I have a device (Kiloview E2) that can output HX2. When set to output to HX2 (recognized ad "NDI" from command line analyzer) the signal work well on OBS for windows, but in Mac I get only the audio. the same if I use Wirecast instead of OBS. all the OBS ndi plugin is the most recent version as well wirecast.

NDI Studio Monitor - disable red and green lines

Par : theliadir
Is it possible to disable those green and red lines in the NDI Studio Monitor?

Here is an image:

Click image for larger version. 

Name:	screen.png 
Views:	17 
Size:	839.3 KB 
ID:	148549
Attached Thumbnails
Click image for larger version. 

Name:	screen.png 
Views:	N/A 
Size:	839.3 KB 
ID:	148549  

NDI Discovery Service - Backup server

Par : simond83
As this is such a crucial link for a large install, can the NDI Access Manager add both a primary and secondary server, so that we can have a backup in case of failure? Thanks!

NDI Virtual Input and FFMPEG/FFplay issues

Par : DWAM
Hi !

I'd like to use Newtek NDI Virtual Input to feed FFMPEG for live encoding to other protocols but I cannot get it to run smoothly and it results in choppy or slomo video, rtbufsize errors, framedrops and cracking audio.

Here's my context :
- Windows 10 64 Bits
- FFMPEG from Zeranoe (latest stable build 4.3.1)
- NDI feeds come from vMix or OBS or NDI Connect and they all play fine everywhere except with FFMPEG (I have fine results with NDI Tools, other vMix/OBS/VLC or Zoom/Skype/WebRTC, etc... they're all working perfectly)

Here's my commandline for FFplay

> ffplay -f dshow -rtbufsize 512M -i video="NewTek NDI Video":audio="Ligne (NewTek NDI Audio)"

> the console returns "real-time buffer [NewTek NDI Video] [video input] too full or near too full (62% of size: 512000000 [rtbufsize parameter])! frame dropped!" and the playback is not good at all

I have also tried with option "-fflags nobuffer" or with a larger (insane?) values for buffer size (-rtbufsize 1024M/2048M). Also tried to specify more options (which help sometimes) like "-vcodec rawvideo" or "-video_size 1920x1080 -framerate 25" but nothing works... Even the FFPROBE utility which only analyses the input reports rtbufsize errors!

Obviously it does the same with FFMPEG so any further conversion (to SRT in my use case) is terribly bad too.

I have a lot of scripts dealing with DSHOW devices in FFMPEG, it's not always easy, but this time, I feel completely stuck. Am I missing something? Did someone managed to get NDI Virtual Input work when used as a DSHOW device in FFMPEG?

Any help appreciated! Thanks
Guillaume, aka DWAM

Scan converter freezes after 7th PC running it

Par : avmw
Hi - We are trying to do an 8 computer setup using NDI and going into vmix or wirecast. We are good to go on 7 connections but once we turn on scan converter on the 8th pc, that one freezes. We have tried it on various PC and have found it happens on the 8th PC no matter what order we connect the PCs.

is there a standard setting we are missing? Do we need a 10g switch? We have a gig switch in line now.

Any suggestions? Is there a limit to how many computers are using the scan converter option?